Oct. 99 Summary: 4 Part Series on Using Help Files Effectively in Quilting Programs.

Part 1: What is in the Help Files and Why Computer Quilters need to learn to use them.

Part 2: Creating your own Help File Reference Manual

Part 3: Optimize your ability to Search your Help Files

Part 4: Modify Help File Content by Adding Information to the Help Files.

Issue 6: October 1999 continued
Editor: Sharla R. Hicks
Newsletter index for all issuesTable of contents for this issue

 


Part 1:

What is in the Help Files?

Why Do Computer Quilters need to learn to use them?

by Sharla Hicks ©1999

Over the last couple of years, the trend for software manuals in the computer industry took a turn toward tutorials. Tutorials often lack the meat of program operations and the meat to program operations are located in the program Help files stored on the computer. The quilting software developers have followed the industry trend and the new upgrades for Quilt-Pro 3 and Electric Quilt 4 manuals are primarily tutorials. The tutorials contain very little information beyond getting up and running, creating a specific quilt, or doing a specific task like exporting or saving a file. Many of the less obvious operations are not even addressed on the printed page.

Another trend in the industry is not to have printed manuals. Creative Impulse, Repligator and QuiltSOFT (when they run out of this print run of manuals) are three software that are following this lead. It makes economical sense and often the saving is passed on down the line to us.

But, what is a computer quilter to do once they get are up to speed on the basic operations covered in the tutorials or there is no program manual? The answer is to go to the program help files. Sounds easy right? Well it not as easy as it sounds. The hunt and peck operation of trying to guess the correct keyword, idea or concept in the find search is often a real test of patience and often produces frustration, annoyance and little actual information. Sound familiar? As much as I love my computer, I still prefer my manuals on real paper to ferret out operation nuances by browsing the table of contents, index, chapter headings, subheadings, and even reading a paragraph or two.

This last spring as I created my classroom manuals for my computer quilting classes for the National Quilting Association annual conference in Omaha, Nebraska, I used the program help files and discovered information that I would never have found on my own with trial and error running of the programs. I also uncovered some hints and tips to make your help file search more manageable and time efficient.

Part 2:

Creating your own Help File Reference Manual

Turns out for me and I suspect for you, the answer IS print out the help files! Now I mean ALL the files pages, every one of them. (Hints coming on how to do this easily) The price, a ream of 3-hole-punched paper, a 2" three-ring binder, some ink for the printer, and a little time, although not as much time as you might think with my nifty hints below. Quilt-Pro 3 and Electric Quilt 4 help files each filled a 2" binder (one-side page printing.) Walla -- now I have the printed word right at my fingertips again.

Probably the best timesaving tip I offer here is the short-cut to printing multiple headings at one time. The following information is generic in nature and will be applicable to all programs that have help files.

1. To open the Help Menu and dialogue box: Click at the end of the Top Menu Bar, then select the highlighted option(s) shown below.

 

select EQ4 Help select contents

 

2. To find Help Content files: Click Contents in the tabs.

3. NOTE: The Help Files are categorized by headings. Each Major/Primary Heading has a series of subheading(s) and topic(s) of information. The actual information and printable pages are in the files marked with the Xxxx Xxxx . (see example below)

 

4. SHORTCUT: To print all subheadings and individual topics under the Major/Primary Heading at the same time:

a. Highlight the Major/Primary heading Hightligted heading in help file contents (DO NOT select the ? page or the indented subheading, those print only a partial section under the Major/Primary Heading)

b. Click print

c. While waiting for the printing to complete, browse the pages that are printing and you will be very surprised by what you will learn and how easy it was to print so many topics at the same time.

5. There is no way to print the Table of Contents or Index Words for the Help files that I found yet (if you know of a way, let me know), nor are the pages numbered for reference, so I created my own reference tabs. After printing each section, I created a tab using a blank 2" x 4" address label folded over the edge of the paper and labeled each section as shown in the Content Headings. (i.e.: Introduction, Creating Blocks, Grids, ETC.) I then staggered the tabs for easier reading.

6. After completing the printing and labeling process, place the printed section in a 3-ring binder in the order of the Contents Index because the Contents Index has a logical progression that makes finding references easier.

7. Now, sit down, experiment, enjoy learning about the real power hidden inside your quilting program. But, first move on to Part 3 and 4 to learn to use the Help Files directly on the computer screen.

Part 3:

Using your Help Files Effectively -- Optimize your Search Capabilities

OK, you are stuck in the program and know you can do something but can not remember the steps, your printed Help Files are not handy, the tutorial manual is not helping and you are growing frustrated. Can you use the Help files effectively? Yes, but remember that the search can be cumbersome and frustrating at times; so, I will try to come to the rescue here and give you some hints to help you optimize your search capabilities.

The first thing you need to do to is rebuild your keywords to maximize your search capabilities. The Quilt-Pro and Electric Quilt Help files are small enough that you can maximize your search capabilities for every word in the file and not create any slow downs in the system. Searching every word enhances your changes of stumbling onto related words or ideas that you are looking for.

Maximize the Keyword Find capabilities with the following steps:

1. After opening up the Help files (use method shown in Part 1):Click find tab from the Contents, Index, Findtabs.

2. To open the Find Setup Wizard dialogue box: Select Rebuild button..

3. Select the Select Maximize search capabilities. There will be a small delay while your program rebuilds the keywords. This methods adds a few nonessential words, but also adds every single word found in the help files allowing you the potential of finding the keyword you are looking.

Now to maximize the possibilities of finding a word, phrase or partial part of word that matches your search needs, change your Find Keyword Search Method by changing your Options.

1. After opening up the Help files (use method shown in Part 1): Click find from the Content,  Index,  Find tabs.

2. To open the Find Options dialogue box: Click Options Button.

3. To maximize your search options: Setup your dialogue box as shown below:

 

Find Options dialogue box.  Select At least One of the words you typed and under Show Words That: select begin with the characters you type

 

Select the following options:

  • Search for topics containing: At least one of the words you typed.

  • Show Words that: Begin with the characters you type.

To save selections, exit the dialogue box: Click .

Another way to maximize your searching efforts is to browse carefully the Contents headings, subheadings and topics list. The list is the Help File's Table of Contents. Reviewing the Contents carefully may trigger a light bulb leading to a search completion.

1. Click on the Contents tab in the Contents, Index, Find tabs.

2. Browse each heading by clicking on the each Closed Book icon to find the subheading(s) and topic(s) open book heading with ? subtitles.

Now that you have a better idea how to search your Help Files effectively. Move to Part 4 to learn how to add to your Content Files.

Part 4:

Modify Help File Content by Adding Information to the Help Files.

You just figured out a nifty trick for using the program and would like to document it in your help files. You wish to record that information permanently in the Help Files, so that it will be at your finger tips in the future. It really is much simpler than you would expect as most computer functions are.

Here are the steps for modifying the help files.

NOTE: You can not modify some of the pages contained in the help files. I have found the pages that I can not change are usually 'How-to' files that need to stay intact that are buried under the ? and topic label topic section. Often they are a color like Yellow.

Another way to determine if a page can be modified is by looking for the following Top Menu Bar in the Help Files:

File  Edit  Bookmark Options Help

1. Browser the Content Tab dialogue box for the document that you want to modify. (Refer above for steps to searching Content.)

2. The pages that can be modified have question markin front of the topic as shown in the example below. Select your topic to modify from the Contents question markListings.

 

example from Content List

 

3. To add to the Help file, use the Annotate dialogue box. The annotate option can be found under the Edit Menu:

To open the Annotate Dialogue Box (see below): Click Edit and select Annotate.

 

Edit Menu Annotate Dialogue Box

 

4. Type your information in the Annotate Dialogue Box.

5. Take note of the Copy, Paste and Delete buttons in the dialogue box.

Copy adds information to the Clipboard to be moved to another location.

  • Hint: You CAN NOT PRINT the Annotated information from the help files, so if you want to print your added information, use the copy feature to move the information to the clipboard and paste it in a word processing program where you can print your information.

Paste can be used to add TEXT ONLY information from another source.

  • Hint: Use to add information gleaned from your e-mail lists.

  • Hint: Use another word processing file to type out the information so that you can spell and grammar check, then Paste the information into the Annotation Dialogue Box.

Delete is used to remove unwanted annotation notes from the help files.

5. To find your annotation, the addition to the Help files:

  • Return to the page where you added the information.
  • Look at the first Paragraph and findPaper Clip. Double Click on the Paper Clip and your annotation will pop-up.

If you have gone through and done each of the exercises outlined above, CONGRATULATION, you are now a seasoned veteran in the use of Help Files and I know for a fact that you have learned more about your quilting software than you thought you would. Now go and enjoy your new found skills in Computer Quilting.


Newsletter index for all issuesTable of contents for this issue